Updated package to mirror aur/i3-gaps-next-git
This commit is contained in:
parent
14e139bb60
commit
f724028ccf
23
.SRCINFO
23
.SRCINFO
|
@ -1,18 +1,19 @@
|
|||
pkgbase = i3-gaps-fullscreen-next-git
|
||||
pkgdesc = A fork of a fork of i3wm tiling window manager, with multi-monitor fullscreen workaround for VMWare, mpv, etc.
|
||||
pkgver = 4.16.1.r178.g31c0f1b8
|
||||
pkgrel = 1
|
||||
pkgver = 4.19.1.r177.g4ea30ca9
|
||||
pkgrel = 2
|
||||
url = https://github.com/Airblader/i3/tree/gaps-next
|
||||
arch = i686
|
||||
arch = x86_64
|
||||
groups = i3
|
||||
groups = i3-vcs
|
||||
license = BSD
|
||||
makedepends = git
|
||||
makedepends = bison
|
||||
makedepends = flex
|
||||
makedepends = asciidoc
|
||||
makedepends = docbook-xsl
|
||||
makedepends = xmlto
|
||||
makedepends = perl
|
||||
makedepends = pkgconfig
|
||||
makedepends = meson
|
||||
depends = xcb-util-keysyms
|
||||
depends = xcb-util-wm
|
||||
depends = libev
|
||||
|
@ -23,24 +24,16 @@ pkgbase = i3-gaps-fullscreen-next-git
|
|||
depends = xcb-util-cursor
|
||||
depends = xcb-util-xrm
|
||||
depends = libxkbcommon-x11
|
||||
optdepends = rxvt-unicode: The terminal emulator used in the default config.
|
||||
optdepends = dmenu: As menu.
|
||||
optdepends = i3lock: For locking your screen.
|
||||
optdepends = i3status: To display system information with a bar.
|
||||
optdepends = perl-json-xs: For i3-save-tree
|
||||
optdepends = perl-anyevent-i3: For i3-save-tree
|
||||
provides = i3-wm
|
||||
conflicts = i3-wm
|
||||
conflicts = i3bar
|
||||
conflicts = i3bar-git
|
||||
conflicts = i3-git
|
||||
conflicts = i3-gaps-git
|
||||
conflicts = i3-gaps
|
||||
conflicts = i3-gaps-next-git
|
||||
options = docs
|
||||
options = !strip
|
||||
source = git://github.com/Airblader/i3#branch=gaps-next
|
||||
source = wm-fullscreen-monitors.patch
|
||||
sha1sums = SKIP
|
||||
sha1sums = 409e143bd326216337195850a08b1b590cba8502
|
||||
|
||||
pkgname = i3-gaps-fullscreen-next-git
|
||||
|
||||
|
|
77
PKGBUILD
77
PKGBUILD
|
@ -1,77 +1,52 @@
|
|||
# Maintainer: Ingo Bürk <admin at airblader dot de>
|
||||
# Maintainer: David Thurstenson <thurstylark@gmail.com>
|
||||
# Contributor: Ingo Bürk <admin at airblader dot de>
|
||||
|
||||
pkgname=i3-gaps-fullscreen-next-git
|
||||
pkgver=4.16.1.r178.g31c0f1b8
|
||||
pkgrel=1
|
||||
pkgver=4.19.1.r177.g4ea30ca9
|
||||
pkgrel=2
|
||||
pkgdesc='A fork of a fork of i3wm tiling window manager, with multi-monitor fullscreen workaround for VMWare, mpv, etc.'
|
||||
arch=('i686' 'x86_64')
|
||||
url='https://github.com/Airblader/i3/tree/gaps-next'
|
||||
license=('BSD')
|
||||
provides=('i3-wm')
|
||||
conflicts=('i3-wm' 'i3bar' 'i3bar-git' 'i3-git' 'i3-gaps-git' 'i3-gaps' 'i3-gaps-next-git')
|
||||
groups=('i3-vcs')
|
||||
conflicts=('i3-wm' 'i3-git' 'i3-gaps')
|
||||
groups=('i3' 'i3-vcs')
|
||||
depends=('xcb-util-keysyms' 'xcb-util-wm' 'libev' 'yajl'
|
||||
'startup-notification' 'pango' 'perl' 'xcb-util-cursor' 'xcb-util-xrm'
|
||||
'libxkbcommon-x11')
|
||||
makedepends=('git' 'asciidoc' 'docbook-xsl' 'xmlto' 'perl' 'pkgconfig')
|
||||
optdepends=('rxvt-unicode: The terminal emulator used in the default config.'
|
||||
'dmenu: As menu.'
|
||||
'i3lock: For locking your screen.'
|
||||
'i3status: To display system information with a bar.'
|
||||
'perl-json-xs: For i3-save-tree'
|
||||
'perl-anyevent-i3: For i3-save-tree')
|
||||
options=('docs' '!strip')
|
||||
source=('git://github.com/Airblader/i3#branch=gaps-next')
|
||||
sha1sums=('SKIP')
|
||||
|
||||
_gitname='i3'
|
||||
makedepends=('git' 'bison' 'flex' 'asciidoc' 'xmlto' 'meson')
|
||||
optdepends=('i3lock: For locking your screen.'
|
||||
'i3status: To display system information with a bar.')
|
||||
options=('docs')
|
||||
source=('git://github.com/Airblader/i3#branch=gaps-next'
|
||||
'wm-fullscreen-monitors.patch')
|
||||
sha1sums=('SKIP'
|
||||
'409e143bd326216337195850a08b1b590cba8502')
|
||||
|
||||
pkgver() {
|
||||
cd "$srcdir/$_gitname"
|
||||
cd "${srcdir}/i3"
|
||||
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd "$_gitname"
|
||||
patch -p1 << EOF
|
||||
diff --git a/include/atoms_NET_SUPPORTED.xmacro b/include/atoms_NET_SUPPORTED.xmacro
|
||||
index a81948a9..096c6229 100644
|
||||
--- a/include/atoms_NET_SUPPORTED.xmacro
|
||||
+++ b/include/atoms_NET_SUPPORTED.xmacro
|
||||
@@ -23,6 +23,7 @@ xmacro(_NET_WM_WINDOW_TYPE_DROPDOWN_MENU)
|
||||
xmacro(_NET_WM_WINDOW_TYPE_TOOLTIP)
|
||||
xmacro(_NET_WM_WINDOW_TYPE_NOTIFICATION)
|
||||
+xmacro(_NET_WM_FULLSCREEN_MONITORS)
|
||||
xmacro(_NET_WM_DESKTOP)
|
||||
xmacro(_NET_WM_STRUT_PARTIAL)
|
||||
EOF
|
||||
cd "${srcdir}/i3"
|
||||
patch -p1 < "../wm-fullscreen-monitors.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$_gitname"
|
||||
|
||||
autoreconf --force --install
|
||||
|
||||
rm -rf build/
|
||||
mkdir -p build && cd build/
|
||||
|
||||
../configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--disable-sanitizers
|
||||
|
||||
# See https://lists.archlinux.org/pipermail/arch-dev-public/2013-April/024776.html
|
||||
make CPPFLAGS+="-U_FORTIFY_SOURCE"
|
||||
cd "i3"
|
||||
arch-meson \
|
||||
-Ddocs=true \
|
||||
-Dmans=true \
|
||||
../build
|
||||
meson compile -C ../build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$_gitname"
|
||||
cd build/
|
||||
cd "i3"
|
||||
DESTDIR="$pkgdir" meson install -C ../build
|
||||
|
||||
make DESTDIR="$pkgdir/" install
|
||||
|
||||
install -Dm644 ../LICENSE \
|
||||
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
||||
install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
diff --git a/include/i3-atoms_NET_SUPPORTED.xmacro.h b/include/i3-atoms_NET_SUPPORTED.xmacro.h
|
||||
index b491da98..620f9b8d 100644
|
||||
--- a/include/i3-atoms_NET_SUPPORTED.xmacro.h
|
||||
+++ b/include/i3-atoms_NET_SUPPORTED.xmacro.h
|
||||
@@ -24,6 +24,7 @@ xmacro(_NET_WM_WINDOW_TYPE_DROPDOWN_MENU) \
|
||||
xmacro(_NET_WM_WINDOW_TYPE_POPUP_MENU) \
|
||||
xmacro(_NET_WM_WINDOW_TYPE_TOOLTIP) \
|
||||
xmacro(_NET_WM_WINDOW_TYPE_NOTIFICATION) \
|
||||
+xmacro(_NET_WM_FULLSCREEN_MONITORS) \
|
||||
xmacro(_NET_WM_DESKTOP) \
|
||||
xmacro(_NET_WM_STRUT_PARTIAL) \
|
||||
xmacro(_NET_CLIENT_LIST) \
|
Loading…
Reference in New Issue